易语言批量取中间文本,如下,结果出错,帮忙看看

今日遇到的问题:“易语言批量取中间文本,如下,结果出错,帮忙看看”

 

.局部变量 存放的数组, 文本型, , "0"

 

返回文本 = 编码_utf8到gb2312 (到文本 (HTTP读文件 (“https://www.xxx.com”)))

编辑框2.内容 = 到文本 (文本_取中间_批量 (返回文本, “前标识符”, “后标识符”, 存放的数组))


网址我用xxx代替了,我随便找的一个网址测试然后失败了,结果就出来了三个数字

哪里出错了?




“易语言批量取中间文本,如下,结果出错,帮忙看看” 解决方法:

.版本 2

 

.程序集 窗口程序集_窗口1

 

.子程序 _窗口1_创建完毕

.局部变量 文本, 文本型

.局部变量 存放数组, 文本型, , "0"

.局部变量 局_计次, 整数型

 

文本 = “<s>gugjhjj</s><s>gugjhjj</s><s>gugjhjj</s><s>gugjhjj</s><s>gugjhjj</s>”

 

文本_取中间_批量 (文本, “<s>”, “</s>”, 存放数组, 假, , , , )

.计次循环首 (取数组成员数 (存放数组), 局_计次)

    输出调试文本 (存放数组 [局_计次])

 

.计次循环尾 ()


相关文章